Mengatasi Configured Repositories Failed - Fedora 21 - ZixIndonesia

Breaking

BANNER 728X90

Monday, 28 September 2015

Mengatasi Configured Repositories Failed - Fedora 21

Fedora - Muncul beberapa yang mungkin akan di alami oleh sejumlah orang pada os fedora v21, dan itulah yang terjadi kepada saya. Terdapat kesalahan pada sistem update pada terminal yang biasa kita ketikan dengan.

Sudo yum update

               Atau
yum update

Untuk error yang terjadi pada melakukan perintah tsb seperti ini :


Mengatasi Configured Repositories Failed - Fedora 21


One of the configured repositories failed (Fedora 21 - x86_64 - Updates),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Disable the repository, so yum won't use it by default. Yum will then
    just ignore the repository until you permanently enable it again or use
    --enablerepo for temporary usage:

        yum-config-manager --disable updates

 4. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=updates.skip_if_unavailable=false

Cannot retrieve metalink for repository: updates/21/x86_64. Please verify its path and try again. 




Bisa kita pertanyakan, mengapa bila terjadi seperti ini ? padahal kita tidak melakukan kesalahan ketikan pada saat menulis perintah yum update pada terminal.


Kesalahan terjadi pada " skip_if_unavailable=false " yang seharusnya kata false itu kita ubah menjadi true.

Dengan cara : 

1.  buka terminal command ( jangan lupa untuk masuk root ) 
  
   $ su
   $ sudo su

2. Ketikan  "gedit /etc/yum.repos.d/fedora.repo" pada terminal

3. Find kata false , dan jadikan true

4. setelah di edit, kemudian klik tombol save pada bagian atas gedit



No comments:

Post a Comment